Skip to end of metadata
Go to start of metadata

Contenu

Informations diverses

Gardez une version de test à portée de main

Après avoir installé et réglé votre boutique afin qu'elle corresponde le mieux à vos besoins, mais avant de l'ouvrir officiellement au public, nous vous recommandons fortement d'installer une version locale de test sur votre ordinateur (à l'aide de WAMP pour Windows, MAMP pour Mac, ou LAMP pour Linux, ou XAMPP pour n'importe laquelle de ces plateformes), ou sur un autre emplacement de votre serveur d'hébergement.

Cette seconde installation vous sera utile en tant qu'environnement de pré-production, sur laquelle vous pourrez tester toutes vos idées de modifications pour votre boutique, sans affecter la boutique en ligne. Ainsi, si une erreur se produit sur cet environnement de test, votre boutique réelle ne serait pas affectée.

Après avoir confirmé que votre version de test fonctionne, copiez ses fichiers sur ceux de votre version en ligne. Il est préférable de faire cette copie en dehors des heures d'affluence, et en ayant pris soin de mettre temporairement votre boutique en mode maintenance.

Vérifiez la bibliothèque GD

La bibliothèque GD permet à PrestaShop de retoucher les images que vous mettez en ligne, notamment d'en changer la taille.

Une installation standard de PHP devrait avoir la bibliothèque GD activée, mais si ce n'est pas le cas pour votre installation, les instructions Windows sont :

  1. Dans le dossier racine de votre dossier PHP, ouvrez le fichier php.ini,
  2. Décommentez a la ligne extension=php_gd2.dll (située vers la moitié du fichier, au milieu d'une longue liste d'extensions) en effaçant le ";" au début de la ligne.
  3. Relancez les services PHP.

Si vous n'avez pas accès au fichier php.ini (ce qui est souvent le cas sur les hébergements mutualisé), contactez votre hébergeur en lui indiquant votre besoin.

Activez PHP5

La plupart du temps, les serveurs dédiés ou mutualisés disposent à la fois de PHP 4 et PHP 5, mais PHP 4 reste encore la version activée par défaut.

Pour installer PrestaShop, PHP 5 doit être activé. Si vous tentez de faire fonctionner PrestaShop avec PHP 4, vous verrez de nombreux messages d'erreur s'afficher, notamment celui-ci :

Voici une liste de procédures pour activer PHP5, en fonction des hébergeurs...

1&1

Ajoutez cette ligne à votre fichier .htaccess :

Pour la réécriture d'URL, ajoutez ces lignes :

Free.fr

Ajoutez cette ligne à votre fichier .htaccess :

OVH

Ajoutez cette ligne à votre fichier .htaccess :

Pour désactiver les variables globales :

GoDaddy

Pour voir votre version de PHP :

  1. Connectez-vous à votre Account Manager.
  2. Dans la section Products, cliquez sur Web Hosting.
  3. À côté du compte d'hébergement que vous voulez utiliser, cliquez sur Launch.

Dans la section Server, vous pourrez voir la version de PHP.

Pour modifier la version de PHP :

  1. Dans le menu Content, sélectionnez Programming Languages.
  2. Sélectionnez la version de PHP que vous souhaitez utiliser, puis cliquez sur Continue.
  3. Cliquez sur Update.

Les modifications peuvent mettre jusqu'à 24h à être prises en compte.

Lunarpages (mutualisé)

  1. Connectez-vous à cPanel. Il devrait se trouver à l'adresse http://www.(votre_domaine).(com/net/org/etc.)/cpanel
  2. Saisissez vos identifiants.
  3. Dans la page qui s'affiche, cliquez sur l'icône "Enable/Disable PHP 5".
  4. Dans la page qui s'affiche, cliquez sur "Add PHP 5 To Your Account!".

Les modifications peuvent mettre jusqu'à 24h à être prises en compte.

  • No labels